Umzug II

Seit Anfang September sind wir, wie berichtet, im WordPress Eigenbetrieb. Das hat viele Vor- aber auch einige Nachteile. Einer ist, dass man seine technische Probleme weitgehend selber lösen muß, zum Beispiel wenn man den Provider wechselt.

Also seit gestern läuft homeiswheremyheartis.net nicht mehr auf 1und1 sondern auf UD Media. Grund war im wesentlichen die stellenweise sauschlechte DB Performance bei 1und1. Hier erhoffen wir uns eine Verbesserung beim neuen Hoster.

Aber der Umzug hatte seine Tücken.
Wie haben wir’s gemacht:

  • Kopieren des kompletten WordPress Verzeichnisses (also inkl. Themes, Plugins, Uploads) auf den neuen Webspace.
  • DB Backup (aus MySQL 4) in die neue Datenbank (MySQL 5) ohne besondere Einstellungen zu ändern (und zu beachten)

Problem:
Sonderzeichen wurden nicht mehr korrekt angezeigt, sowohl im FF als auch im IE. Zuerst haben wir vernmutet, dass irgendeine Einstellung beim Hoster nicht OK ist, nach einem Telefonat mit der UD Media Hotline wurde aber schnell klar, dass es daran wohl nicht liegt.

Nach einiger Suche in diversen Foren (u.a. dem deutschen WP Forum) und dem studieren diverser Beiträge und FAQs, haben wir folgende Lösung realisiert.

  • generelles Umstellen des Blog Zeichensatzes auf iso-8859-1
  • beim Importieren des Backups wurde als Zeichenkodierung latin1 eingestellt. Eine Kontrolle direkt in der DB ergibt, es werden ä, ö, ü und ß in den Tabelleneinträgen angezeigt, im Blog auch.

Mit diesen Einstellungen scheint jetzt wieder alles korrekt zu funktionieren. Umlaute in Titel, Einträgen, Tags und Kommentaren werden korrekt angezeigt. Auch die Suche nach Wörtern mit Umlauten funktioniert (Allerdings nur wenn die Umlaute auch so in der DB eingetragen sind, d.h. wenn B?r als ‚Bär‘ (?=ä) gecodet ist, dann nicht. Wer mehr weiß, möchte bitte kommentieren)

Darüber hinaus mußten noch Berechtigungen angepaßt werden, damit z.B. Uploads und Backup aus der WordPress Oberfl?che (oder einem BlogClient) heraus funktionieren.
In diesem Zusammenhang finde ich es interessant, dass ich dazu bei 1und1 keinerlei Änderungen an den default Einstellungen vorgenommen habe und es funktioniert hat.

Resüme: Einen guten halben Nachmittag gebastelt, jetzt gehts erstmal …. 😉

verwandte Einträge

4 Gedanken zu “Umzug II”

  1. Hi Nib, erstmal Gratulation zum erfolgreichem Umzug!
    Die Ladezeiten haben sich zwar verbessert, aber ich glaube gefunden zu haben, was deine Seitenladezeit so derart verzögert. Ich habe mal die Zeiten der Hauptseite mit der Ladezeit eines einzelen Artikels verglichen (37 queries. 4.537 seconds ./. 21 queries. 0.244 seconds). Aufgefallen ist mir, das du auf der Einzelseite keine flickr-Bilder lädst. Vielleicht ist ja da auch der Kasus-Knacktus vergraben. Ich hab mein Blog bei netclusive.de liegen, Hauptseite macht 21 Datenbankabfragen in 0.300 Sekunden, und ein Artikel macht 20 Datenbankabfragen in 0.270 Sekunden. Könntest du ja mal testen, indem du in der Sidebar den Flickr-Abschnitt auskommentierst. 🙂

    Liebe Grüße
    mobe

  2. Mario,
    alle Zeiten unter 5s sind *imho* schon gut, idR scheinen im Moment die Zeiten um eine Sekunde zu liegen. Die Anzahl der Queries hängt wohl vom verwendeten Theme ab und dem, was auf den Seiten alles aus der Datenbank angezeigt wird.
    Siehe auch WordPress Perormance Einbrüche..

    Bei 1und1 gab es oft Abfragezeiten in der Gegend von 30s und manchmal sogar bis zu 100s oder keine Datenbankverbindung. Besonders lästig ist das beim Bearbeiten eines Artikels, wenn das zurückspeichern in die DB dann mehrere Minuten dauert.

Schreibe einen Kommentar

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.